现在的位置: 首页 > WordPress教程 > 正文

WordPress后台提示“在向 API 发送请求时发生了一个 HTTP 异常错误”

2012年09月06日 WordPress教程 ⁄ 共 783字 暂无评论 ⁄ 阅读 2,006 次

笨鸟的wordpress博客前段时间出了一些小问题,在搜索插件时出现“在向 API 发送请求时发生了一个 HTTP 异常错误”提示。出现这种问题就无法通过博客安装寻找插件了,会带来很多麻烦。而后,笨鸟又测试了搜索主题,结果也出现“在向 API 发送请求时发生了一个 HTTP 异常错误”提示。

wordpress-api错误

连续出现这个错误提示,让笨鸟想到在一次wordpress 3.4.1程序自动升级时发生过一次错误。莫非是这个错误引发的问题?不过后来笨鸟通过wordpress手动升级已经解决过了升级问题,按道理不应该再出现问题的。

遇到这种难题,笨鸟又把博客所有功能检查了一遍,结果发现不只是这些问题,有些插件也开始出现问题了。比如,“WordPress Database Backup”插件不自动发送备份,自动发送备份功能失效;“Baidu Sitemap Generator”插件不自动更新地图等。这仅仅是笨鸟所使用的为数不多的几个插件里目前已发现出现问题的插件(笨鸟仅装了四款插件,不建议过多使用插件,能不用尽量不用)。

api异常错误

综上,大概出现“在向 API 发送请求时发生了一个 HTTP 异常错误”提示后问题有:

1、无法通过wordpress API平台搜索插件;

2、无法通过后台搜索wordpress主题;

3、WordPress Database Backup自动备份插件失效;

4、Baidu Sitemap Generator百度地图插件失效;

出现这些问题后笨鸟仔细检查了程序,跟懂php的朋友咨询,跟服务器运营商客服咨询,都无法解决。后台笨鸟只能测试,在原主机上安装了新的wordpress程序,结果发现问题了!新程序也出现了这样的问题,然后笨鸟又把网站搬到其他主机上,程序就正常了!通过这些不难找到原因了,是主机设置的问题!

而后,笨鸟跟主机运营商“华夏名网”取得联系,说明原因并要求更新其他服务器,服务器更换后问题就完美解决了!

» 声明:本站文章源于个人经验总结或书籍、互联网转载,内容仅用于个人学习,请勿转载,否则后果自负!

给我留言

留言无头像?